Excel Tipp 56: Nur Arbeitstage anzeigen

In diesem Excel-Tipp erfahren Sie, wie nur die Arbeitstage/ Werktage fortlaufend aus einem Datum angezeigt werden

PRAXIS-TIPP

Testen Sie gerne die

Wenn wir in Microsoft Excel im Controlling, oder einer anderen Abteilung, die fortlaufenden Tage und Datum anzeigen lassen möchten, ist dies relativ leicht.

 

Hierzu geben wir in einer Zelle, in diesem Beispiel Zelle C3, ein Startdatum ein. Unter der Zelle C3 schreiben wir einfach die folgende Formel:

 

=C3+1

 

und kopieren die Formel beliebig hinunter.

 

Um jetzt den jeweiligen Wochentag zu sehen, schreiben wir einfach die folgende Formel in die Zelle D3:

 

=WOCHENTAG(C3;2)

 

und es wird uns, nachdem wir mit Enter bestätigt haben, eine 4 angezeigt. Die Nummer 4 wäre hier der Donnerstag, also der vierte Tag der Woche.

 

Damit wir den Wochentag als Text und nicht als Nummer angezeigt bekommen, erweitern wir die Formel ein wenig und erstellen eine Hilfstabelle.

 

In den Zellen F3 bis F9 schreiben wir die Nummern 1 bis 7 und daneben die Wochentage Montag bis Sonntag.

 

Excel nur Arbeitstage anzeigen lassen, fortlaufend aus Datum

Wir gehen zurück in unsere Formel in der Zelle D3 und erweitern diese wie folgt:

 

=SVERWEIS(WOCHENTAG(C3;2);$F$3:$G$9;2;0)

 

Diese Formel kopieren wir nun hinunter und sehen die jeweiligen Wochentage als Text vom Datum.

 

Excel nur Arbeitstage anzeigen, fortlaufend aus Datum

 

Kommen wir nun zum Problem. Nicht immer sollen die Samstage und Sonntage angezeigt werden, sondern nur die Arbeitstage bzw. Werktage.

 

Lösung: In Excel nur die Arbeitstage fortlaufend anzeigen lassen

Damit uns in diesem Beispiel nur die Wochentage von Montag bis Freitag angezeigt werden, schreiben wir in die Zelle C4 folgende Formel:

 

=C3+1+(WOCHENTAG(C3;2)=5)*2

 

Diese Formel kopieren wir nun hinunter und die Samstage und Sonntage werden übersprungen.

 

Excel nur die Arbeitstage anzeigen

 

Die Formel =C3+1+(WOCHENTAG(C3;2)=5)*2 lässt sich wie folgt erklären.

 

Im ersten Schritt wird das Datum wie im einfachen Beispiel lediglich plus 1 addiert.

Als nächstes wird der Wochentag aus dem Datum vom vorigen Tag ermittelt.

Mit =5 wird geprüft ob es sich um einen Freitag, fünfter Wochentag, handelt und mit 2 multipliziert. Somit wird dann ein Montag ermittelt.

 

Handelt es sich um keinen Freitag wird dieser Wert als FALSCH ermittelt. Wenn dieser mit 2 multipliziert wird, wird mit dem Wert 0 addiert. Bei einem Freitag ist der Wert WAHR bzw. 1.

 

Ich wünsche Ihnen viel Spaß beim Ausprobieren.

 

 

WEITERE EXCEL-TIPPS

 

Autor

Kristoffer Ditz ist Leiter der Hanseatic Business School in Hamburg und freiberuflicher Dozent an der AMD Akademie Mode und Design / Hochschule Fresenius. 

 

Er verfügt über mehrere Jahre Berufserfahrung u.a. bei der Puma AG, Ludwig Beck AG, Dänisches Bettenlager und der Hamburger Drogeriemarktkette Iwan Budnikowsky.

 

Für das Controlling Journal und Controller Magazin schreibt er regelmäßig Fachartikel zu den Themen Controlling und Microsoft Excel.