Excel Tipp 42: SVERWEIS nach links

In diesem Excel-Tipp erfahren Sie, wie Sie den Spaltenindex (SVERWEIS) nach links setzen können

Wenn wir in Excel umfangreiche Tabellen mit mehreren Spalten erstellen und dann einen Begriff mit dem dazugehörigen Wert aus einer Spalte definieren möchten, kommt oft die Formel SVERWEIS ins Spiel der Excel-Formeln.

 

Nun kommt es allerdings auch einmal vor, dass in einer Tabelle, aufgrund der Zuordnung,

ein Wert nicht rechts von den Begriffen sondern links davon stehen.

 

Dies ist hauptsächlich dann der Fall, wenn die Tabelle bzw. die Auswertungen erweitert werden sollen.

 

Bevor jetzt eine weitere Tabellen-Struktur mit der richtigen Anordnung erstellt wird, gibt es hierfür auch eine andere Funktion, die mit der SVERWEIS-Funktion verwendet werden kann.

 

Sehen wir uns für dieses Beispiel einmal die folgende Tabelle an:

 

Excel Tipp: SVERWEIS nach links

 

In dieser Tabelle sehen wir einmal die Kunden-Nummer, den dazugehörigen Lieferanten und wie viele Aufträge erzielt wurden.

 

Wenn wir jetzt in der Zelle F3 den Lieferanten wählen und die Anzahl der Aufträge in der Zelle G3  ermitteln möchten, würde hier folgende Formel greifen

 

=SVERWEIS(F3;C3:D6;2;0)

 

Excel Tipp: SVERWEIS nach links

 

Sollte allerdings nun der Fall eintreten, dass Sie nicht die Anzahl der Aufträge sondern die Kunden-Nr anzeigen lassen möchten, würde die Formel nur noch funktionieren, wenn die Kundennummern in der Tabelle rechts vom Lieferanten stehen würden.

 

Bevor sie jetzt die Kundennummern zusätzlich nach rechts verschieben, so dass diese ggf. doppelt in der Tabelle vorhanden sind, zum Beispiel wenn Sie auch die Kundennummern als Suchkriterium verwenden, können Sie die SVERWEIS-Formel ein wenig umbauen.

 

Verwenden Sie folgende Formel:

 

=SVERWEIS(F3;WAHL({2.1};B3:B6;C3:C6);2;0)

 

Excel Tipp: SVERWEIS nach links

 

Bei dieser Funktion wurde hier die Funktion "WAHL" mit dem Wert 2.1 verwendet.

Als erster Wert werden die Zellen definiert, die den Zielwert enthalten und als nächstes folgen die Zellen, welche ausgewählt werden (Zelle F3) bzw. Suchkriterium.

 

Dies wäre eine Möglichkeit, wie Sie den SVERWEIS so einsetzen, dass dieser einen "Blick" nach links wirft. Selbstverständlich gibt es in Excel noch zahlreiche weitere Möglichkeiten, doch hier wird explizit die SVERWEIS-Funktion beschrieben.

 

Ich wünsche Ihnen viel Spaß beim Ausprobieren.

 

 

 

WEITERE EXCEL-TIPPS

 

 

Autor

Kristoffer Ditz ist Leiter der Hanseatic Business School in Hamburg und freiberuflicher Dozent an der AMD Akademie Mode und Design / Hochschule Fresenius. 

 

Er verfügt über mehrere Jahre Berufserfahrung u.a. bei der Puma AG, Ludwig Beck AG, Dänisches Bettenlager und der Hamburger Drogeriemarktkette Iwan Budnikowsky.

Für das Controlling Journal und Controller Magazin schreibt er regelmäßig Fachartikel.                          

Für Sie vielleicht auch interessant:


Strategie-Toolbox

EUR 99,00

Personal-Toolbox

EUR 99,00 

Projekt-Toolbox

EUR 79,00

Finanz-Paket

EUR 99,00